Boot Up Issue ProTrack I

SHerchik

Boot Up Issue ProTrack I
« on: March 06, 2015, 11:49:50 am »
I have been tasked with repairing a Huntron ProTrack I. When I turn it on the LCD displays the name, then says Calibrating Offsets.  After that the screen gets a dark line across the top of it and dark lines flash and scroll down it, until the display eventually goes blank.  The CRT never turns on as far as I can tell, but voltages are present at the back of it.  None of the buttons seem to function either.  Any ideas?

admin

  • Huntronian
  • 405
    • HUNTRON.COM
    • Email
Re: Boot Up Issue ProTrack I
« Reply #1 on: March 09, 2015, 07:17:06 am »
Welcome to the Huntron Support Forum.

It sounds like the ProTrack is not finishing the boot up sequence so it could be a program issue. However, before we try anything fancy I would suggest that you open the ProTrack case and carefully reseat all connectors and socketed ICs. The ProTracks are getting pretty old now so it is possible some connector contacts are getting intermittent.
The most important troubleshooting tool is your eyes.

SHerchik

Re: Boot Up Issue ProTrack I
« Reply #2 on: March 09, 2015, 08:08:52 am »
That was the first thing that I tried, but it hasn't seemed to help at all.  Occasionally I do get different displays on the LCD (Half of the display is blank, or no display at all).  They all result the same though, the buttons still don't work and the CRT never shows anything.  The A side input light comes on but that is all.

admin

  • Huntronian
  • 405
    • HUNTRON.COM
    • Email
Re: Boot Up Issue ProTrack I
« Reply #3 on: March 09, 2015, 01:05:27 pm »
Can you get the ProTrack to connect to a PC? If yes, then there is a shot at getting the program reloaded. If no, then sending it to Huntron should be considered.
The most important troubleshooting tool is your eyes.

SHerchik

Re: Boot Up Issue ProTrack I
« Reply #4 on: March 10, 2015, 05:53:50 am »
No unfortunately, I will contact the owner about returning it to Huntron for repair.  Thank you.

jvthorsley

  • 208
  • Do what you do well, and if a Huntron helps use it
    • www.jhorsley.com
    • Email
Re: Boot Up Issue ProTrack I
« Reply #5 on: April 22, 2015, 03:35:50 pm »
Have you checked the low voltage supplies? 12 V.D.C. and 5 volt logic supply.
I may be able to help here.
I have two Pro Track 1's, one developed a fault on the HV supply and I had to modify the circuit as mentioned on previous
message here.

admin

  • Huntronian
  • 405
    • HUNTRON.COM
    • Email
Re: Boot Up Issue ProTrack I
« Reply #6 on: April 23, 2015, 07:08:03 am »
James' suggestion is good.
You can measure the voltages at the connection to the Main PCA. Pin1: 15V; Pin 2 and 3: 5V; Pin 4 and 5: GND; Pin 6: -15V
The most important troubleshooting tool is your eyes.

jvthorsley

  • 208
  • Do what you do well, and if a Huntron helps use it
    • www.jhorsley.com
    • Email
Re: Boot Up Issue ProTrack I
« Reply #7 on: February 24, 2019, 08:02:50 am »
Some while back I know but for anyone else looking at this fault, try reprogramming the Flash Prom on the ProTrack.
Give Curtis the serial number and he can email the program I believe. No promises here!!!
But best to copy the contents of the Flash Prom first before it gets corrupted.
The TL866 Universal Programmer on EBay does a good job here
Its mounted on the main board under the Parallel or USB and Digitizer cards in position U60.
That is on a ProTrack KJ2 version.
« Last Edit: February 26, 2019, 11:08:09 am by jvthorsley »